NASは、ローカルバックアップの保存先として最も一般的なもののひとつです。しかし、保護対象のPCやサーバーに直接接続されていないため、セットアップ時や、場合によっては数か月後に、いくつかの予測可能な問題が発生することがあります。
ここでは、NASに関する問題やその傾向を紹介し、それぞれの最も可能性の高い原因について解説します。ただしバックアップソフトウェアによっては、異なる特有の不具合や対処法がある場合があります。
Q: NASをバックアップデバイスとして追加しようとしても表示されない、または「バックアップソースを参照できません」というエラーが表示される
➡️ バックアップサービスは通常、ログイン中のWindowsセッションではなく、「ローカル システム」アカウントで実行されます。ユーザー自身としてマッピングしたドライブ文字は、そのアカウントには存在しません。マップされたドライブは使用せず、代わりにデバイスの設定で完全なUNCパス(\server-name\share または \192.168.x.x\share)を指定してください。もう1つのよくある原因は、NASがまだデバイスリストに追加されていないことです。
Q: 他の場所ではログインに問題がないにもかかわらず、デバイスを追加しようとした瞬間に「無効な認証情報」というエラーが表示される
➡️ これは認証情報の問題であることはめったにありません。その同じ共有先を指しているマッピングされたドライブや開いているエクスプローラーのウィンドウが接続を維持しており、それがアクティブな間は、Windows が異なる認証情報での再認証を許可しないためです。マッピングされたドライブの接続を解除し、そのパスを参照しているエクスプローラーのウィンドウをすべて閉じてから、もう一度試してください。
Q: 接続自体は問題なく行えるが、バックアップジョブ自体が、毎日使用しているフォルダに対して「アクセスが拒否されました」というエラーを返す
➡️ あなたのWindowsユーザーにはアクセス権限があります。バックアップジョブが実行されるアカウントにはアクセス権限がない可能性があります。たまたまログインしているユーザーではなく、そのパスに対する明示的な権限を持つ特定のWindowsユーザーとしてジョブを実行するように設定してください。
Q: 数週間はバックアップが正常に動作していたが、設定変更を行っていないにもかかわらず、再起動やWindowsアップデート後に停止してしまった
➡️ マップされたドライブのセッションが終了しました。マップされたドライブは、それを作成したログイン中のセッションにのみ存在するため、そのセッションをリセットする操作(再起動、ログオフ、更新)が行われると、ジョブが依存している接続が切断されます。UNCパスにはそのような依存関係がないため、最初からその方法でNASを追加することを勧めます。
Q: 停電後に「ネットワークパスが見つかりません」または「デバイスがオフラインです」というエラーでジョブが失敗する
➡️ バックアップソフトウェアの設定を変更する前に、2つの点を確認してください。まず、NASは再起動しましたか?多くのNASは、停電後にデフォルトで電源がオフのままになります。NASの管理パネルで電源復旧設定を探し、自動的に電源が入るように設定してください。次に、NASがDHCPからIPアドレスを取得している場合、ルーターまたはNASを再起動することで新しいアドレスが割り当てられることがあります。バックアップデバイスがIPアドレスで追加されていた場合、ソフトウェアは現在、応答のないアドレスを指していることになります。NASに静的IPアドレスを割り当てるか、ルーターでDHCP予約を設定してください。さらに良いのは、ホスト名(\server-name\share)でデバイスを追加することです。そうすれば、IPアドレスが変更されてもジョブが中断されることはありません。


